Docker install with ubuntu 22.04 image

Hello,
First, I’m able to install PrivacyIDEA on Ubuntu 22.04 withou problem, great docs and software :wink:
Now, in order to go to production env, I need to install PrivacyIDEA on Docker.

So, I create this DockerFile, based on the install process here

FROM ubuntu:22.04
RUN apt update
RUN apt install -y wget systemctl gpg
RUN wget https://lancelot.netknights.it/NetKnights-Release.asc && gpg --import --import-options show-only --with-fingerprint NetKnights-Release.asc
RUN mv NetKnights-Release.asc /etc/apt/trusted.gpg.d/
RUN echo "deb http://lancelot.netknights.it/community/jammy/devel jammy main" >> /etc/apt/sources.list
RUN apt update
RUN apt-get install -y privacyidea-radius
RUN apt-get install -y apt-utils dialog
RUN apt install -y privacyidea-nginx
CMD tail -f /dev/null

I still have to finish this Dockerfile for prod env but that’s another problem :wink:

During an installation without Docker, after the command “apt install -y privacyidea-nginx” it seems that a script or process takes over (with mysql it seems to me) and the PrivacyIdea banner appears, to then complete the installation correctly.

With Docker, I get stuck at the “apt install -y privacyidea-nginx” command and nothing happens.
I tried with the “DEBIAN_FRONTEND=noninteractive” option but it didn’t change anything.

I tried to finish building my container without the command “apt install -y privacyidea-nginx”, then to place myself in the container, then to launch myself the command “apt install -y privacyidea-nginx”, but nothing does not happen.

Would it be possible to have precisions what it occurs with the installation of this .deb? With a simultaneous connection to the container, I can see that these processes are launched, but I can’t do anything more:

root          17  3.5  0.7  72752 62432 pts/0    S+   14:34   0:00 apt install -y privacyidea-nginx
root          48  0.0  0.0   7508  4052 pts/1    Ss+  14:34   0:00 /usr/bin/dpkg --status-fd 27 --configure --pending
root          49  0.1  0.1  18752 15892 pts/1    S+   14:34   0:00 /usr/bin/perl -w /usr/share/debconf/frontend /var/lib/dpkg/info/privacyidea-nginx.postinst configure
root          56  0.0  0.0      0     0 pts/1    Z+   14:34   0:00 [privacyidea-ngi] <defunct>
mysql         86 14.0  4.7 2312172 389040 ?      Ssl  14:34   0:02 /usr/sbin/mysqld

Many Thanks for your precious help !

I am not an expert in Docker. But to my understanding you must not install the package, which contains the database and the webserver with several processes in one container.

If you want to install privacyIDEA in docker, you need to be an expert in docker.

Ok thanks for your answer.