"Unknown value Perl for attribute Auth-Type" in Freeradius

Hello there

I’ve installed Privacyidea on Debian Wheezy and tried to configure
Freeradius plugin based on your documentation. Everything seems OK, till I
add “DEFAULT Auth-Type := Perl” to the users file in Freeradius directorey,
then the Freeradius service doesn’t start and its log file shows these:

Fri Aug 14 15:10:10 2015 : Info: Signalled to terminate
Fri Aug 14 15:10:10 2015 : Info: Exiting normally.
Fri Aug 14 15:10:10 2015 : Error: /etc/freeradius/users[1]: Parse error
(check) for entry DEFAULT: Unknown value Perl for attribute Auth-Type
Fri Aug 14 15:10:10 2015 : Error: Errors reading /etc/freeradius/users
Fri Aug 14 15:10:10 2015 : Error: /etc/freeradius/modules/files[7]:
Instantiation failed for module "files"
Fri Aug 14 15:10:10 2015 : Error:
/etc/freeradius/sites-enabled/default[170]: Failed to load module “files”.
Fri Aug 14 15:10:10 2015 : Error:
/etc/freeradius/sites-enabled/default[69]: Errors parsing authorize
section.
Fri Aug 14 15:10:10 2015 : Error: Failed to load virtual server

I’m going to get access to the Active Directory users so the AD users can
be read thru LDAP and I can authenticate a test user which I set in
Freeradius users file, by the help of NTRadPing test utility throughout the
AD server.
I’ve searched for the Freeradius errors but I could not find any solution
to this problem.

Any help would be appreciate!

It contains “default, inner-tunnel” files by default and "privacyidea"
created by linking to the privacyidea file in sites-available.

Hi Cornelius,

The help is very much appreciated. I’ve got the correct package installed
already and had what you suggested in my mods-enabled/perl file.

That gave me:
/etc/raddb/mods-enabled/perl[7]: Configuration item “module” is deprecated
/etc/raddb/mods-enabled/perl[7]: Replace “module” with “filename”

So I did what it told me and changed it to filename = .pmfilepatch which
got me to the error I posted in my earlier message.

Thanks
SamOn Monday, 24 August 2015 13:32:25 UTC+1, Cornelinux K wrote:

Hi Sam,

this seems simple.

The error is, that the Auth-Type “Perl” is not known.

But it looks like the perl module on centos is contained in the package
freeradius-perl.

    yum install freeradius-perl 

On CentOS the freeradius config is organized in a slightly different
way, which I do not know.
Start by adding

    /etc/raddb/mods-enabled/perl 

with the contents like

perl {
module = /usr/share/privacyidea/freeradius/privacyidea_radius.pm
}

Kind regards
Cornelius

Am Montag, den 24.08.2015, 04:54 -0700 schrieb Sam Weston:

I have the exact same problem on CentOS 7. I’m using 2.6dev0 because
older versions have a dependency problem when installing via pip.
Removing default and inner-tunnel sadly doesn’t help.

I’m following this
documentation:
http://privacyidea.readthedocs.org/en/latest/application_plugins/index.html?highlight=freeradius

Here is the end of the radiusd -X output:

Loaded module rlm_files

Instantiating module “files” from

file /etc/raddb/mods-enabled/files
files {
filename = "/etc/raddb/mods-config/files/authorize"
usersfile = "/etc/raddb/mods-config/files/authorize"
acctusersfile = "/etc/raddb/mods-config/files/accounting"
preproxy_usersfile = “/etc/raddb/mods-config/files/pre-proxy"
compat = “cistron”
}
reading pairlist file /etc/raddb/mods-config/files/authorize
/etc/raddb/mods-config/files/authorize[57]: Parse error (check) for
entry DEFAULT: Unknown value ‘Perl’ for attribute 'Auth-Type’
Failed reading /etc/raddb/mods-config/files/authorize
/etc/raddb/mods-enabled/files[9]: Instantiation failed for module
"files”

I might just give up and install on Ubuntu 14.04

Sam

On Saturday, 15 August 2015 16:11:29 UTC+1, Cornelinux K wrote:
Remove default and inner-tunnel.

    Kind regards 
    Cornelius 
    
    
    
    
    
    
    Cornelius Kölbel 
    Corneliu...@netknights.it 
    +49 151 2960 1417 
    
    
    NetKnights GmbH 
    http://netknights.it 
    Landgraf-Karl-Str. 19, 34131 Kassel, Germany 
    Tel: +49 561 3166797, Fax: +49 561 3166798 
    
    
    Amtsgericht Kassel, HRB 16405 
    Geschäftsführer: Cornelius Kölbel 
    
    
    -------- Ursprüngliche Nachricht -------- 
    Von: Houmanic <houm...@gmail.com> 
    Datum: 15.08.2015 09:26 (GMT+01:00) 
    An: privacyidea <priva...@googlegroups.com> 
    Cc: houm...@gmail.com 
    Betreff: Re: "Unknown value Perl for attribute Auth-Type" in 
    Freeradius 
    
    It contains "default, inner-tunnel" files by default and 
    "privacyidea" created by linking to the privacyidea file in 
    sites-available. 


Cornelius Kölbel
corneliu...@netknights.it <javascript:>
+49 151 2960 1417

NetKnights GmbH
http://www.netknights.it
Landgraf-Karl-Str. 19, 34131 Kassel, Germany
Tel: +49 561 3166797, Fax: +49 561 3166798

Amtsgericht Kassel, HRB 16405
Geschäftsführer: Cornelius Kölbel

Hi Sam,

this seems simple.

The error is, that the Auth-Type “Perl” is not known.

But it looks like the perl module on centos is contained in the package
freeradius-perl.

yum install freeradius-perl

On CentOS the freeradius config is organized in a slightly different
way, which I do not know.
Start by adding

/etc/raddb/mods-enabled/perl

with the contents like

perl {
module = /usr/share/privacyidea/freeradius/privacyidea_radius.pm
}

Kind regards
CorneliusAm Montag, den 24.08.2015, 04:54 -0700 schrieb Sam Weston:

I have the exact same problem on CentOS 7. I’m using 2.6dev0 because
older versions have a dependency problem when installing via pip.
Removing default and inner-tunnel sadly doesn’t help.

I’m following this
documentation: http://privacyidea.readthedocs.org/en/latest/application_plugins/index.html?highlight=freeradius

Here is the end of the radiusd -X output:

Loaded module rlm_files

Instantiating module “files” from

file /etc/raddb/mods-enabled/files
files {
filename = “/etc/raddb/mods-config/files/authorize”
usersfile = “/etc/raddb/mods-config/files/authorize”
acctusersfile = “/etc/raddb/mods-config/files/accounting”
preproxy_usersfile = “/etc/raddb/mods-config/files/pre-proxy”
compat = “cistron”
}
reading pairlist file /etc/raddb/mods-config/files/authorize
/etc/raddb/mods-config/files/authorize[57]: Parse error (check) for
entry DEFAULT: Unknown value ‘Perl’ for attribute ‘Auth-Type’
Failed reading /etc/raddb/mods-config/files/authorize
/etc/raddb/mods-enabled/files[9]: Instantiation failed for module
“files”

I might just give up and install on Ubuntu 14.04

Sam

On Saturday, 15 August 2015 16:11:29 UTC+1, Cornelinux K wrote:
Remove default and inner-tunnel.

    Kind regards
    Cornelius
    
    
    
    
    
    
    Cornelius Kölbel
    Corneliu...@netknights.it
    +49 151 2960 1417
    
    
    NetKnights GmbH
    http://netknights.it
    Landgraf-Karl-Str. 19, 34131 Kassel, Germany
    Tel: +49 561 3166797, Fax: +49 561 3166798
    
    
    Amtsgericht Kassel, HRB 16405
    Geschäftsführer: Cornelius Kölbel
    
    
    -------- Ursprüngliche Nachricht --------
    Von: Houmanic <houm...@gmail.com> 
    Datum: 15.08.2015 09:26 (GMT+01:00) 
    An: privacyidea <priva...@googlegroups.com> 
    Cc: houm...@gmail.com 
    Betreff: Re: "Unknown value Perl for attribute Auth-Type" in
    Freeradius 
    
    It contains "default, inner-tunnel" files by default and
    "privacyidea" created by linking to the privacyidea file in
    sites-available.


Cornelius Kölbel
@cornelinux
+49 151 2960 1417

NetKnights GmbH
http://www.netknights.it
Landgraf-Karl-Str. 19, 34131 Kassel, Germany
Tel: +49 561 3166797, Fax: +49 561 3166798

Amtsgericht Kassel, HRB 16405
Geschäftsführer: Cornelius Kölbel

signature.asc (836 Bytes)

I have the exact same problem on CentOS 7. I’m using 2.6dev0 because older
versions have a dependency problem when installing via pip. Removing
default and inner-tunnel sadly doesn’t help.

I’m following this
documentation: http://privacyidea.readthedocs.org/en/latest/application_plugins/index.html?highlight=freeradius

Here is the end of the radiusd -X output:

Loaded module rlm_files

Instantiating module “files” from file /etc/raddb/mods-enabled/files

files {
filename = "/etc/raddb/mods-config/files/authorize"
usersfile = "/etc/raddb/mods-config/files/authorize"
acctusersfile = "/etc/raddb/mods-config/files/accounting"
preproxy_usersfile = "/etc/raddb/mods-config/files/pre-proxy"
compat = “cistron”
}
reading pairlist file /etc/raddb/mods-config/files/authorize
/etc/raddb/mods-config/files/authorize[57]: Parse error (check) for entry
DEFAULT: Unknown value ‘Perl’ for attribute 'Auth-Type’
Failed reading /etc/raddb/mods-config/files/authorize
/etc/raddb/mods-enabled/files[9]: Instantiation failed for module “files”

I might just give up and install on Ubuntu 14.04

SamOn Saturday, 15 August 2015 16:11:29 UTC+1, Cornelinux K wrote:

Remove default and inner-tunnel.

Kind regards
Cornelius

Cornelius Kölbel
Corneliu...@netknights.it <javascript:>
+49 151 2960 1417

NetKnights GmbH
http://netknights.it
Landgraf-Karl-Str. 19, 34131 Kassel, Germany
Tel: +49 561 3166797, Fax: +49 561 3166798

Amtsgericht Kassel, HRB 16405
Geschäftsführer: Cornelius Kölbel

-------- Ursprüngliche Nachricht --------
Von: Houmanic <houm...@gmail.com <javascript:>>
Datum: 15.08.2015 09:26 (GMT+01:00)
An: privacyidea <priva...@googlegroups.com <javascript:>>
Cc: houm...@gmail.com <javascript:>
Betreff: Re: “Unknown value Perl for attribute Auth-Type” in Freeradius

It contains “default, inner-tunnel” files by default and "privacyidea"
created by linking to the privacyidea file in sites-available.


You received this message because you are subscribed to the Google Groups
"privacyidea" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to privacyidea...@googlegroups.com <javascript:>.
To post to this group, send email to priva...@googlegroups.com
<javascript:>.
To view this discussion on the web visit
https://groups.google.com/d/msgid/privacyidea/8636bcf8-f5fb-4d01-984b-53e90e68f7ee%40googlegroups.com
https://groups.google.com/d/msgid/privacyidea/8636bcf8-f5fb-4d01-984b-53e90e68f7ee%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

Hi Sam,

I realize centos 7 uses freeradius 3 which has a slightly different
configuration.

The differences between freeradius 2 and 3 are here:
http://wiki.freeradius.org/modules/Rlm_perl

But honestly I also fail getting it to work.

I will post a request on the freeradius mailing list.

Kind regards
CorneliusAm Montag, den 24.08.2015, 07:22 -0700 schrieb Sam Weston:

Hi Cornelius,

The help is very much appreciated. I’ve got the correct package
installed already and had what you suggested in my mods-enabled/perl
file.

That gave me:
/etc/raddb/mods-enabled/perl[7]: Configuration item “module” is
deprecated
/etc/raddb/mods-enabled/perl[7]: Replace “module” with “filename”

So I did what it told me and changed it to filename = .pmfilepatch
which got me to the error I posted in my earlier message.

Thanks
Sam

On Monday, 24 August 2015 13:32:25 UTC+1, Cornelinux K wrote:
Hi Sam,

    this seems simple. 
    
    The error is, that the Auth-Type "Perl" is not known. 
    
    But it looks like the perl module on centos is contained in
    the package 
    freeradius-perl. 
    
            yum install freeradius-perl 
    
    On CentOS the freeradius config is organized in a slightly
    different 
    way, which I do not know. 
    Start by adding 
    
            /etc/raddb/mods-enabled/perl 
    
    with the contents like 
    
    perl { 
        module
    = /usr/share/privacyidea/freeradius/privacyidea_radius.pm 
    } 
    
    
    Kind regards 
    Cornelius 
    
    Am Montag, den 24.08.2015, 04:54 -0700 schrieb Sam Weston: 
    > I have the exact same problem on CentOS 7. I'm using 2.6dev0
    because 
    > older versions have a dependency problem when installing via
    pip. 
    > Removing default and inner-tunnel sadly doesn't help. 
    > 
    > 
    > I'm following this 
    > documentation:
    http://privacyidea.readthedocs.org/en/latest/application_plugins/index.html?highlight=freeradius 
    > 
    > 
    > Here is the end of the radiusd -X output: 
    > 
    > 
    >   # Loaded module rlm_files 
    >   # Instantiating module "files" from 
    > file /etc/raddb/mods-enabled/files 
    >   files { 
    >   filename = "/etc/raddb/mods-config/files/authorize" 
    >   usersfile = "/etc/raddb/mods-config/files/authorize" 
    >   acctusersfile = "/etc/raddb/mods-config/files/accounting" 
    >   preproxy_usersfile =
    "/etc/raddb/mods-config/files/pre-proxy" 
    >   compat = "cistron" 
    >   } 
    > reading pairlist
    file /etc/raddb/mods-config/files/authorize 
    > /etc/raddb/mods-config/files/authorize[57]: Parse error
    (check) for 
    > entry DEFAULT: Unknown value 'Perl' for attribute
    'Auth-Type' 
    > Failed reading /etc/raddb/mods-config/files/authorize 
    > /etc/raddb/mods-enabled/files[9]: Instantiation failed for
    module 
    > "files" 
    > 
    > 
    > I might just give up and install on Ubuntu 14.04 
    > 
    > 
    > Sam 
    > 
    > On Saturday, 15 August 2015 16:11:29 UTC+1, Cornelinux K wrote: 
    >         Remove default and inner-tunnel. 
    >         
    >         
    >         Kind regards 
    >         Cornelius 
    >         
    >         
    >         
    >         
    >         
    >         
    >         Cornelius Kölbel 
    >         Corneliu...@netknights.it 
    >         +49 151 2960 1417 
    >         
    >         
    >         NetKnights GmbH 
    >         http://netknights.it 
    >         Landgraf-Karl-Str. 19, 34131 Kassel, Germany 
    >         Tel: +49 561 3166797, Fax: +49 561 3166798 
    >         
    >         
    >         Amtsgericht Kassel, HRB 16405 
    >         Geschäftsführer: Cornelius Kölbel 
    >         
    >         
    >         -------- Ursprüngliche Nachricht -------- 
    >         Von: Houmanic <houm...@gmail.com> 
    >         Datum: 15.08.2015 09:26 (GMT+01:00) 
    >         An: privacyidea <priva...@googlegroups.com> 
    >         Cc: houm...@gmail.com 
    >         Betreff: Re: "Unknown value Perl for attribute
    Auth-Type" in 
    >         Freeradius 
    >         
    >         It contains "default, inner-tunnel" files by default
    and 
    >         "privacyidea" created by linking to the privacyidea
    file in 
    >         sites-available. 
    >         
    >         
    > 
    > 
    -- 
    Cornelius Kölbel 
    corneliu...@netknights.it 
    +49 151 2960 1417 
    
    NetKnights GmbH 
    http://www.netknights.it 
    Landgraf-Karl-Str. 19, 34131 Kassel, Germany 
    Tel: +49 561 3166797, Fax: +49 561 3166798 
    
    Amtsgericht Kassel, HRB 16405 
    Geschäftsführer: Cornelius Kölbel 

Winner of IHS Jane’s ATC Award - Enabling Technology
Read more

You received this message because you are subscribed to the Google
Groups “privacyidea” group.
To unsubscribe from this group and stop receiving emails from it, send
an email to privacyidea+unsubscribe@googlegroups.com.
To post to this group, send email to privacyidea@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/privacyidea/2bad3da2-6685-4fab-a909-d2f0a0b16f66%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


Cornelius Kölbel
@cornelinux
+49 151 2960 1417

NetKnights GmbH
http://www.netknights.it
Landgraf-Karl-Str. 19, 34131 Kassel, Germany
Tel: +49 561 3166797, Fax: +49 561 3166798

Amtsgericht Kassel, HRB 16405
Geschäftsführer: Cornelius Kölbel

signature.asc (836 Bytes)

Hi Sam,

please try this configuration:

in sites-enabled/privacyidea do:

authorize {
[…]
update control {
Auth-Type := Perl
}
}

and in the authenticate section:

authenticate {
Auth-Type Perl {
perl
}
}

Then place the privacyidea perl module somewhere like
/etc/raddb/mods-config/perl/privacyidea.pm

and in /etc/raddb/mods-enabled/perl do a
filename = ${modconfdir}/${.:instance}/privacyidea.pm

That worked for me.

Running CentOS 7 contains feeradius 3, which also comes with rlm_python.
Maybe we should provide a nice python module… :slight_smile:

Kind regards
CorneliusAm Dienstag, den 25.08.2015, 08:48 +0200 schrieb Cornelius Kölbel:

Hi Sam,

I realize centos 7 uses freeradius 3 which has a slightly different
configuration.

The differences between freeradius 2 and 3 are here:
http://wiki.freeradius.org/modules/Rlm_perl

But honestly I also fail getting it to work.

I will post a request on the freeradius mailing list.

Kind regards
Cornelius

Am Montag, den 24.08.2015, 07:22 -0700 schrieb Sam Weston:

Hi Cornelius,

The help is very much appreciated. I’ve got the correct package
installed already and had what you suggested in my mods-enabled/perl
file.

That gave me:
/etc/raddb/mods-enabled/perl[7]: Configuration item “module” is
deprecated
/etc/raddb/mods-enabled/perl[7]: Replace “module” with “filename”

So I did what it told me and changed it to filename = .pmfilepatch
which got me to the error I posted in my earlier message.

Thanks
Sam

On Monday, 24 August 2015 13:32:25 UTC+1, Cornelinux K wrote:
Hi Sam,

    this seems simple. 
    
    The error is, that the Auth-Type "Perl" is not known. 
    
    But it looks like the perl module on centos is contained in
    the package 
    freeradius-perl. 
    
            yum install freeradius-perl 
    
    On CentOS the freeradius config is organized in a slightly
    different 
    way, which I do not know. 
    Start by adding 
    
            /etc/raddb/mods-enabled/perl 
    
    with the contents like 
    
    perl { 
        module
    = /usr/share/privacyidea/freeradius/privacyidea_radius.pm 
    } 
    
    
    Kind regards 
    Cornelius 
    
    Am Montag, den 24.08.2015, 04:54 -0700 schrieb Sam Weston: 
    > I have the exact same problem on CentOS 7. I'm using 2.6dev0
    because 
    > older versions have a dependency problem when installing via
    pip. 
    > Removing default and inner-tunnel sadly doesn't help. 
    > 
    > 
    > I'm following this 
    > documentation:
    http://privacyidea.readthedocs.org/en/latest/application_plugins/index.html?highlight=freeradius 
    > 
    > 
    > Here is the end of the radiusd -X output: 
    > 
    > 
    >   # Loaded module rlm_files 
    >   # Instantiating module "files" from 
    > file /etc/raddb/mods-enabled/files 
    >   files { 
    >   filename = "/etc/raddb/mods-config/files/authorize" 
    >   usersfile = "/etc/raddb/mods-config/files/authorize" 
    >   acctusersfile = "/etc/raddb/mods-config/files/accounting" 
    >   preproxy_usersfile =
    "/etc/raddb/mods-config/files/pre-proxy" 
    >   compat = "cistron" 
    >   } 
    > reading pairlist
    file /etc/raddb/mods-config/files/authorize 
    > /etc/raddb/mods-config/files/authorize[57]: Parse error
    (check) for 
    > entry DEFAULT: Unknown value 'Perl' for attribute
    'Auth-Type' 
    > Failed reading /etc/raddb/mods-config/files/authorize 
    > /etc/raddb/mods-enabled/files[9]: Instantiation failed for
    module 
    > "files" 
    > 
    > 
    > I might just give up and install on Ubuntu 14.04 
    > 
    > 
    > Sam 
    > 
    > On Saturday, 15 August 2015 16:11:29 UTC+1, Cornelinux K wrote: 
    >         Remove default and inner-tunnel. 
    >         
    >         
    >         Kind regards 
    >         Cornelius 
    >         
    >         
    >         
    >         
    >         
    >         
    >         Cornelius Kölbel 
    >         Corneliu...@netknights.it 
    >         +49 151 2960 1417 
    >         
    >         
    >         NetKnights GmbH 
    >         http://netknights.it 
    >         Landgraf-Karl-Str. 19, 34131 Kassel, Germany 
    >         Tel: +49 561 3166797, Fax: +49 561 3166798 
    >         
    >         
    >         Amtsgericht Kassel, HRB 16405 
    >         Geschäftsführer: Cornelius Kölbel 
    >         
    >         
    >         -------- Ursprüngliche Nachricht -------- 
    >         Von: Houmanic <houm...@gmail.com> 
    >         Datum: 15.08.2015 09:26 (GMT+01:00) 
    >         An: privacyidea <priva...@googlegroups.com> 
    >         Cc: houm...@gmail.com 
    >         Betreff: Re: "Unknown value Perl for attribute
    Auth-Type" in 
    >         Freeradius 
    >         
    >         It contains "default, inner-tunnel" files by default
    and 
    >         "privacyidea" created by linking to the privacyidea
    file in 
    >         sites-available. 
    >         
    >         
    > 
    > 
    -- 
    Cornelius Kölbel 
    corneliu...@netknights.it 
    +49 151 2960 1417 
    
    NetKnights GmbH 
    http://www.netknights.it 
    Landgraf-Karl-Str. 19, 34131 Kassel, Germany 
    Tel: +49 561 3166797, Fax: +49 561 3166798 
    
    Amtsgericht Kassel, HRB 16405 
    Geschäftsführer: Cornelius Kölbel 

Winner of IHS Jane’s ATC Award - Enabling Technology
Read more

You received this message because you are subscribed to the Google
Groups “privacyidea” group.
To unsubscribe from this group and stop receiving emails from it, send
an email to privacyidea+unsubscribe@googlegroups.com.
To post to this group, send email to privacyidea@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/privacyidea/2bad3da2-6685-4fab-a909-d2f0a0b16f66%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


Cornelius Kölbel
@cornelinux
+49 151 2960 1417

NetKnights GmbH
http://www.netknights.it
Landgraf-Karl-Str. 19, 34131 Kassel, Germany
Tel: +49 561 3166797, Fax: +49 561 3166798

Amtsgericht Kassel, HRB 16405
Geschäftsführer: Cornelius Kölbel


Cornelius Kölbel
@cornelinux
+49 151 2960 1417

NetKnights GmbH
http://www.netknights.it
Landgraf-Karl-Str. 19, 34131 Kassel, Germany
Tel: +49 561 3166797, Fax: +49 561 3166798

Amtsgericht Kassel, HRB 16405
Geschäftsführer: Cornelius Kölbel

signature.asc (836 Bytes)