[solved] Credential Provider DummyCustomer subscription import error

Hey guys,

my privacyIDEA server is up and running and I would like to test the multifactor auth in Windows.
Unfortunately, when I try to import the “2022-12-31_Dummy.Customer_privacyIDEA-CP.sub” from Github, I get the following error message:
SubscriptionError('Verifying the signature of your subscription failed.', application=privacyIDEA-CP)

Is this still a valid method to test the Credential Provider or do I need to contact NetKnights directly?

Also, I may ask how is the signature verified? My server is behind an internal proxy if that could be an issue…

Thanks in advance

Have a nice day!

Hi and welcome to the privacyIDEA…
…community.

My guess is you installed privacyidea via pip?

Then you need to manually add the the file NetKnights.pem into your directory /etc/privacyidea/.

After that, importing the Credential Provider Demo Subscription should work out like a charme.
Regards
Cornelius

1 Like

Hi Cornelius,

thanks a lot, now it works as expected!

Best regards
Jens

1 Like