Setup translation

Dear Cornelius

We’re going to apply the translation over the site and did the instruction
from the manual. The grunt and its dependencies have been installed.
However, the “make translate” command cannot find the “Rule” (for test).
Tthere is no “po” directory anywhere and I cannot find any “pot” file
related to the package.

Am I missing something?

Yes, I did.
And yes, I know that it just contains the German language for now. I run
"make translate" just to test how the translation can apply and find out
how it looks. However, the command reply is: “make: *** No rule to make
target ‘translate’. Stop.”

So it seems it cannot find the related translate file, wherever I run it.
Afterwards, based on the instructoin, I installed the grunt and it plugins
in the package directory: / usr
https://192.168.1.10:10000/filemin/index.cgi?path=%2Fusr / lib
https://192.168.1.10:10000/filemin/index.cgi?path=%2Fusr%2Flib / python2.7
https://192.168.1.10:10000/filemin/index.cgi?path=%2Fusr%2Flib%2Fpython2.7
/ dist-packages
https://192.168.1.10:10000/filemin/index.cgi?path=%2Fusr%2Flib%2Fpython2.7%2Fdist-packages
/ privacyidea
https://192.168.1.10:10000/filemin/index.cgi?path=%2Fusr%2Flib%2Fpython2.7%2Fdist-packages%2Fprivacyidea
It creates node_modules directory, however the instruction asked to change
the directory to “po” which is not available in the whole system. As I
learn from the grunt documents, the translation file are in “.pot” format
which are not available for the package as well.On Monday, January 4, 2016 at 5:41:40 PM UTC+3:30, Cornelius Kölbel wrote:

Hello Houman,

Did you follow the instructions in the FAQ?

http://privacyidea.readthedocs.org/en/latest/faq/index.html#how-can-i-translate-to-my-language

You do not need to run “make translate”. The normal "Make translate"
only contains the german language. Oher languages could be added.

Which command did produce which error exactly?

Kind regards
Cornelius

Am Montag, den 04.01.2016, 04:49 -0800 schrieb Houmanic:

Dear Cornelius

We’re going to apply the translation over the site and did the
instruction from the manual. The grunt and its dependencies have been
installed. However, the “make translate” command cannot find the
"Rule" (for test). Tthere is no “po” directory anywhere and I cannot
find any “pot” file related to the package.

Am I missing something?


You received this message because you are subscribed to the Google
Groups “privacyidea” group.
To unsubscribe from this group and stop receiving emails from it, send
an email to privacyidea...@googlegroups.com <javascript:>.
To post to this group, send email to priva...@googlegroups.com
<javascript:>.
To view this discussion on the web visit

https://groups.google.com/d/msgid/privacyidea/be5124b6-67f0-4018-8b35-bb0d504244a5%40googlegroups.com.

For more options, visit https://groups.google.com/d/optout.


Cornelius Kölbel
corneliu...@netknights.it <javascript:>
+49 151 2960 1417

NetKnights GmbH
http://www.netknights.it
Landgraf-Karl-Str. 19, 34131 Kassel, Germany
Tel: +49 561 3166797, Fax: +49 561 3166798

Amtsgericht Kassel, HRB 16405
Geschäftsführer: Cornelius Kölbel

Hello Houman,

To do the translation you need to clone the git repository!

 git clone https://github.com/privacyidea/privacyidea.git

Then you need to run

make translate

in the top level directory.

The Makefile there has a target “translate”.

Please follow the howto to install grunt locally:

npm update -g npm

install grunt cli in system

sudo npm install -g grunt-cli

install grunt in project directory

npm install grunt --save-dev

Install grunt gettext plugin

npm install grunt-angular-gettext --save-dev

The po/ directory is also at the top level directory.

Kind regards
CorneliusAm Montag, den 04.01.2016, 07:24 -0800 schrieb Houmanic:

Yes, I did.
And yes, I know that it just contains the German language for now. I
run “make translate” just to test how the translation can apply and
find out how it looks. However, the command reply is: “make: *** No
rule to make target ‘translate’. Stop.”

So it seems it cannot find the related translate file, wherever I run
it. Afterwards, based on the instructoin, I installed the grunt and it
plugins in the package directory: / usr / lib / python2.7 /
dist-packages / privacyidea
It creates node_modules directory, however the instruction asked to
change the directory to “po” which is not available in the whole
system. As I learn from the grunt documents, the translation file are
in “.pot” format which are not available for the package as well.

On Monday, January 4, 2016 at 5:41:40 PM UTC+3:30, Cornelius Kölbel wrote:
Hello Houman,

    Did you follow the instructions in the FAQ? 
    http://privacyidea.readthedocs.org/en/latest/faq/index.html#how-can-i-translate-to-my-language 
    
    You do not need to run "make translate". The normal "Make
    translate" 
    only contains the german language. Oher languages could be
    added. 
    
    Which command did produce which error exactly? 
    
    Kind regards 
    Cornelius 
    
    
    
    
    
    
    Am Montag, den 04.01.2016, 04:49 -0800 schrieb Houmanic: 
    > Dear Cornelius 
    > 
    > We're going to apply the translation over the site and did
    the 
    > instruction from the manual. The grunt and its dependencies
    have been 
    > installed. However, the "make translate" command cannot find
    the 
    > "Rule" (for test).  Tthere is no "po" directory anywhere and
    I cannot 
    > find any "pot" file related to the package. 
    > 
    > Am I missing something? 
    > 
    > -- 
    > You received this message because you are subscribed to the
    Google 
    > Groups "privacyidea" group. 
    > To unsubscribe from this group and stop receiving emails
    from it, send 
    > an email to privacyidea...@googlegroups.com. 
    > To post to this group, send email to
    priva...@googlegroups.com. 
    > To view this discussion on the web visit 
    >
    https://groups.google.com/d/msgid/privacyidea/be5124b6-67f0-4018-8b35-bb0d504244a5%40googlegroups.com. 
    > For more options, visit https://groups.google.com/d/optout. 
    
    -- 
    Cornelius Kölbel 
    corneliu...@netknights.it 
    +49 151 2960 1417 
    
    NetKnights GmbH 
    http://www.netknights.it 
    Landgraf-Karl-Str. 19, 34131 Kassel, Germany 
    Tel: +49 561 3166797, Fax: +49 561 3166798 
    
    Amtsgericht Kassel, HRB 16405 
    Geschäftsführer: Cornelius Kölbel 


You received this message because you are subscribed to the Google
Groups “privacyidea” group.
To unsubscribe from this group and stop receiving emails from it, send
an email to privacyidea+unsubscribe@googlegroups.com.
To post to this group, send email to privacyidea@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/privacyidea/ee8602ff-f504-40e5-b1d2-3e8955a1b716%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


Cornelius Kölbel
@cornelinux
+49 151 2960 1417

NetKnights GmbH
http://www.netknights.it
Landgraf-Karl-Str. 19, 34131 Kassel, Germany
Tel: +49 561 3166797, Fax: +49 561 3166798

Amtsgericht Kassel, HRB 16405
Geschäftsführer: Cornelius Kölbel

signature.asc (836 Bytes)

Hello Houman,

Did you follow the instructions in the FAQ?
http://privacyidea.readthedocs.org/en/latest/faq/index.html#how-can-i-translate-to-my-language

You do not need to run “make translate”. The normal “Make translate”
only contains the german language. Oher languages could be added.

Which command did produce which error exactly?

Kind regards
CorneliusAm Montag, den 04.01.2016, 04:49 -0800 schrieb Houmanic:

Dear Cornelius

We’re going to apply the translation over the site and did the
instruction from the manual. The grunt and its dependencies have been
installed. However, the “make translate” command cannot find the
“Rule” (for test). Tthere is no “po” directory anywhere and I cannot
find any “pot” file related to the package.

Am I missing something?


You received this message because you are subscribed to the Google
Groups “privacyidea” group.
To unsubscribe from this group and stop receiving emails from it, send
an email to privacyidea+unsubscribe@googlegroups.com.
To post to this group, send email to privacyidea@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/privacyidea/be5124b6-67f0-4018-8b35-bb0d504244a5%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


Cornelius Kölbel
@cornelinux
+49 151 2960 1417

NetKnights GmbH
http://www.netknights.it
Landgraf-Karl-Str. 19, 34131 Kassel, Germany
Tel: +49 561 3166797, Fax: +49 561 3166798

Amtsgericht Kassel, HRB 16405
Geschäftsführer: Cornelius Kölbel

signature.asc (836 Bytes)