Quieting down dev env: how to disable welcome messages & ascii art?

While working on a local, dev instance, it’s useful to minimize ‘noise’.

Out of the box, PI

(1) on each sign-in, pops up four separate ‘Welcome’ dialogs re: getting an SLA, etc. each requires a dismiss click.

&

(2) on each exec of ‘pi-manage’ @ shell, returns/prints an ascii-art logo

For the 1st, reading @

https://netknights.it/en/welcome-dialog-and-privacyidea-subscription/

states the dialog can be deactivated, at least for ‘small’ installs,

The administrator can define a policy (scope=webui, action=hide_welcome) which deactivates this welcome dialog. Anyway, if you run privacyIDEA with more than 50 assigned tokens and without subscription/SLA, we think it is a good idea, to warn the administrator again about the intrinsic risk running a software without warranty. The welcome dialog will be displayed again.

I set a policy

pi-manage policy create welcome_disable webui hide_welcome

check that it’s in-place & active

pi-manage policy list
	Active   Name    Scope
	========================================
	True     welcome_disable         webui

but, still @ each login, the dialogs pop up.

What specifically needs to be done to quiet these dialogs?

For the 2nd, the source of the ascii-art is in the ‘pi-manage’ script itself,

bin/pi-manage
	...
	if __name__ == '__main__':
	    # We add one blank line, to separate the messages from the initialization
	    print("""
	             _                    _______  _______
	   ___  ____(_)  _____ _______ __/  _/ _ \/ __/ _ |
	  / _ \/ __/ / |/ / _ `/ __/ // // // // / _// __ |
	 / .__/_/ /_/|___/\_,_/\__/\_, /___/____/___/_/ |_|
	/_/                       /___/
	   """)
	    manager.run()

Short of rm’ing those lines, is there a flag/policy to set that disables that shell output?

I am sorry, the action is wrong. It has to be:

pi-manage policy create welcome_disable webui hide_welcome_info

You can check this in the webui! There you might have guessed, that the “hide_welcome” is wrong.

No.

You can check this in the webui! There you might have guessed, that the “hide_welcome” is wrong.

at this early stage of the getting-started game, I’m not ‘guessing’ – I’m actually reading, and attempting to follow, the ‘docs’!

No.

np. I’ll patch it out.

since you’re inviting ‘feedback’ for next release, for any small terminal window one’s working it, wasteful scroll of window content is, at best, noisy & annoying.

perhaps consider a pi.cfg-file override value (PI_SHELL_MSG="") as a usability enhancement?

Most people would configure the policies via the webui. And in this case it would have been obvious, that it is hide_welcome_info.
I never talked to any getting-started guy, who configured a policy via the command line.

different strokes! :slight_smile:

I never (ok, seldom) deploy a tool for my own use, let alone recommend it gets used for business, unless I can I can demonstrate to myself that I can shed all the UI cruft and get to functional install/setup/config via command line.

So that’s where I always start.

In this case, that included reading your post

https://netknights.it/en/welcome-dialog-and-privacyidea-subscription/

which was simply the 1st result from a google search

https://www.google.com/search?&q=privacyidea+disable+welcome+dialog

obvious

sigh. folks use that alot about their own creations/focus. I know I do …

I assumed that your post would be ‘obviously’ correct. My bad. So thx for clarifying.

I never talked to any getting-started guy, who configured a policy via the command line.

well, now it’s not ‘never’ anymore :wink:

I am not responsible for Google’s ranking in search decisions.
This is a blog post, no technical specification or documentation.
At least when I issue the Google search the 2nd and 3rd hit contain the word “documentation”, indicating that this might be also an interesting place to read.

riiight. cuz I haven’t, and its crystal clear …