PrivacyIdea3+pushToken on ownCloud…

…doesn’t work as expected.

Everything done by the “books”:

  • install privacyIdea 3.0.2 on Ubuntu 16.04;
  • install ownCloud on a separate server, Ubuntu 18.04;
  • install privacyIdea app 2.5.2 on this instance of ownCloud;
  • install privacyIdea authenticator 2.0.1 on Android (Pixel).
    All servers and the smartphone on the same subnet…

Follow this writeup to allow for push tokens to be used

Create a new realm and resolver on the privacyIdea server.
Create a new user. Create a push token for this user.
Use privacyIdea authenticator on the Pixel to enroll (scan the QR code).
Get a new Pushtoken to show up in the list of tokens on the phone…

Going back to the ownCloud server, open the privacyIdea configuration page.
Enter the URL for the privacyIdea server.
In the Test section enter the username of the user on the privacyIdea server with an assigned push token.

Press Test…

A notification pops up on the Pixel to confirm login, just as expected.
Press Confirm and a “Authentication successful!” message pops up…

But before these last two events happen, a message next to the Test button pops up
“Communication to the privacyIdea server succeeded. However, the user failed to authenticate”

I also tried activating privacyIdea on ownCloud for just one group with one user.
Again, I get the push notification, confirm, get “Authentication successful!” but no login…

It looks like the two events - working push tokens and its usage - are NOT linked to each other.

So, my first question would be: does the 2.5.2 version of the ownCloud app support push tokens?

If so, what I’m doing wrong?

Thanks in advance.

When I assign the same user a different token (tried TOTP), everything works as expected…

Checking the Challenge Response box and entering privacyIdea server admin credentials does not affect the behaviour…

I believe this explains it: you need v.2.6 of the ownCloud app for it to work with push tokens

Will wait for its release…

Hi and welcome to the forum,

You are right, currently the ownCloud plugin does not work with push-tokens, but we are going to release the new plugin soon.

The server requirement has also changed: v.3.1+…