PrivacyIdea 3.0 WebUI - Internet Explorer

Hi, just wondering if anybody has got the WebUI working with Internet Explorer and privacyIDEA 3.0.
I know it’s not the best browser to be using but one of our clients that i was hoping to get going on it are using a 2008 terminal server which has IE set as the only browser.

I noticed one of the other clients we are using this with Privacy Idea 2 works ok on Internet Explorer.


You know, that the Internet Explorer actually is no browser, but only a “compatibility solution”? :wink:
Sorry, could not resist.

1 Like

The problem with IE is, that there are thousands of possible devestating configuration options, which block web sites from working.
Acutally there is roughly “nothing” that has changed in the UI from 2.23 to 3.0.
I have not tested 3.0 with IE - why would I?
So I rather assume, that you have some strange settings in your IE - especially since you tell nothing about how “it does not work”.

1 Like

To build on his issue description, IE 11 just shows a blank page. While I agree that IE is an ancient browser that needs to be put out to pasture, we too have many users who still utilize it. Having support for at least IE 11 would be nice. Pulling up the console in IE (F12>Console tab), the following errors are displayed (internal domain URLs sanitized):


First error:

Second error:

Disabling Compatibility View yields a different error:

1 Like

I believe I have found the issue. It relates to the u2f.js utilizing let…of which is not supported by IE11. And IE11 doesn’t support u2f anyway. I replaced the for…let…of…loop with the below one and the page loads. Note: This SHOULDN’T affect anything, as a for…of loop is just an easier way to do an iterative one.

                    for (var i=0; i<signRequests.length; i++) {
                        var signRequest = signRequests[i];
                            version: signRequest.version,
                            keyHandle: signRequest.keyHandle

I can confirm @droo 's code works in our production environment. The default icon looks NAAASTY (lots of aliasing and whitespace) but it works.

1 Like

Yeah the only way to fix that is to actually scale the image down and not use the browser scaling for IE. Microsoft removed all of the downscaling filtering in IE10+ for some reason. Hopefully the Chromium replacement of Edge can push out IE11 in corporate environments sooner than later.

I created a pull request with the minor javascript change that fixes the issue.

1 Like

Thanks for your help with this everyone, is there an easy way to apply this fix to my build? If not could someone let me know that path to the file that needs updating?
Thanks again!

The file in question is located at /opt/privacyidea//lib/python2.7/site-packages/privacyidea/static/components/login/factories/u2f.js

You can get the modified file from my fork if you don’t want to modify yours yourself.

droobah/privacyidea - u2f.js

1 Like

This worked great! Thanks so much for your help, I ended up editing the file myself and it worked ok.

Thanks again