Ldapresolver - Exception('Wrong credentials')


I have successfully installed privacyID3A on Ubuntu Server 22.04, and the website is accessible; everything appears to be functioning correctly.

However, I encounter a persistent issue when attempting to connect my Microsoft Active Directory Server as an LDAP resolver. Each attempt results in the error message: “Exception(‘Wrong credentials’)”.

Here is an excerpt from the debug log:

[DEBUG][privacyidea.lib.resolvers.LDAPIdResolver:1141] Traceback (most recent call last):
File “/opt/privacyidea/lib/python3.10/site-packages/privacyidea/lib/resolvers/LDAPIdResolver.py”, line 1101, in testconnection
raise Exception(“Wrong credentials”)
Exception: Wrong credentials

I have double-checked the credentials multiple times and tried various usernames and passwords, but the error persists.

Am I missing something?

Best regards,


the error message is very precise. You configured wrong credentials. i.e. a wrong Bind DN and/or a wrong Bind Password.

But we can not know, since we do not know, what you configured.

The issue is resolved. It was due to a GPO blocking LDAP connections… LDAPS is now working…


thank you for the reply.

I configured it like this:

I also tried test@domain.com and domain\test. But still not working.


1 Like