Http SMS

Hi
I try To move from linotp to privacyidea but i have a problem with http sms.
in linotp the setting work fine i can get sms otp the linotp setting are:

{“URL”:“http://1.1.111/scripts/smsgate.asp”,
“PARAMETER”: {
“username”:“user”,
“password”:“password”,
“validity”:“3”,
“source”:“ssl vpn otp”
},
“SMS_TEXT_KEY”:“message”,
“SMS_PHONENUMBER_KEY”:“target”,
“HTTP_Method”:“GET”,
“RETURN_SUCCESS”:“0”
}

I made the setting in privacyidea but its not working .

Thanks

Dani

https://lh3.googleusercontent.com/-Tc7Q11OWX8Y/WJlkhhokbtI/AAAAAAAAAJI/1bi9TY63R3UoHzno6KrlQiQLrFwwV2VWACLcB/s1600/pic1.JPG

Thanks it is working now

DaniOn Tuesday, February 7, 2017 at 8:10:26 AM UTC+2, Dani Bittan wrote:

Hi
I try To move from linotp to privacyidea but i have a problem with http
sms.
in linotp the setting work fine i can get sms otp the linotp setting are:

{“URL”:“http://1.1.111/scripts/smsgate.asp”,
“PARAMETER”: {
“username”:“user”,
“password”:“password”,
“validity”:“3”,
“source”:“ssl vpn otp”
},
“SMS_TEXT_KEY”:“message”,
“SMS_PHONENUMBER_KEY”:“target”,
“HTTP_Method”:“GET”,
“RETURN_SUCCESS”:“0”
}

I made the setting in privacyidea but its not working .

Thanks

Dani

https://lh3.googleusercontent.com/-Tc7Q11OWX8Y/WJlkhhokbtI/AAAAAAAAAJI/1bi9TY63R3UoHzno6KrlQiQLrFwwV2VWACLcB/s1600/pic1.JPG

Hi Dani,

first of all: Good Choice! :wink:

Then:
DO NOT use the USERNAME and PASSWORD in the top settings. As stated, these
are used for basic authentication!
You need to leave this blank, since you do not use basic authentication. In
your case the usernam and password are passed as HTTP parameters. You need
to add these under options.
And in addion, you need to not add a column at the end of the options. It
should look like this:

https://lh3.googleusercontent.com/-fUhx_gc_UzI/WJmhVv9betI/AAAAAAAAADc/BPP5M116wR0s4OdN_IN7LPdCVX_RNqczgCLcB/s1600/Bildschirmfoto%2Bvom%2B2017-02-07%2B11-28-12.png

Then you can also take a look into the privacyidea.log, which might give
you some clues, in case you do not receive the SMS.

Kind regards
CorneliusAm Dienstag, 7. Februar 2017 07:10:26 UTC+1 schrieb Dani Bittan:

Hi
I try To move from linotp to privacyidea but i have a problem with http
sms.
in linotp the setting work fine i can get sms otp the linotp setting are:

{“URL”:“http://1.1.111/scripts/smsgate.asp”,
“PARAMETER”: {
“username”:“user”,
“password”:“password”,
“validity”:“3”,
“source”:“ssl vpn otp”
},
“SMS_TEXT_KEY”:“message”,
“SMS_PHONENUMBER_KEY”:“target”,
“HTTP_Method”:“GET”,
“RETURN_SUCCESS”:“0”
}

I made the setting in privacyidea but its not working .

Thanks

Dani

https://lh3.googleusercontent.com/-Tc7Q11OWX8Y/WJlkhhokbtI/AAAAAAAAAJI/1bi9TY63R3UoHzno6KrlQiQLrFwwV2VWACLcB/s1600/pic1.JPG

This is a known issue, if you previously used the above username field!
You must delete the SMS gateway and create a new one.
DO NOT add anything to the above username or password!

Kind regards
CorneliusAm Dienstag, den 07.02.2017, 05:16 -0800 schrieb Dani Bittan:

Hi,

even when i right the user name and password in options when i save
the sms gateway it remove them from option
and right them in parameters.

Dani

Hi Dani,

first of all: Good Choice! :wink:

Then:
DO NOT use the USERNAME and PASSWORD in the top settings. As
stated, these are used for basic authentication!
You need to leave this blank, since you do not use basic
authentication. In your case the usernam and password are passed as
HTTP parameters. You need to add these under options.
And in addion, you need to not add a column at the end of the
options. It should look like this:

Then you can also take a look into the privacyidea.log, which might
give you some clues, in case you do not receive the SMS.

Kind regards
Cornelius

Hi
I try To move from linotp to privacyidea but i have a problem
with http sms.
in linotp the setting work fine i can get sms otp the linotp
setting are:

{“URL”:“http://1.1.111/scripts/smsgate.asp”,
“PARAMETER”: {
“username”:“user”,
“password”:“password”,
“validity”:“3”,
“source”:“ssl vpn otp”
},
“SMS_TEXT_KEY”:“message”,
“SMS_PHONENUMBER_KEY”:“target”,
“HTTP_Method”:“GET”,
“RETURN_SUCCESS”:“0”
}

I made the setting in privacyidea but its not working .

Thanks

Dani


Please read the blog post about getting help
https://www.privacyidea.org/getting-help/.

For professional services and consultancy regarding two factor
authentication please visit
https://netknights.it/en/leistungen/one-time-services/

In an enterprise environment you should get a SERVICE LEVEL AGREEMENT
which suites your needs for SECURITY, AVAILABILITY and LIABILITY:
https://netknights.it/en/leistungen/service-level-agreements/

You received this message because you are subscribed to a topic in
the Google Groups “privacyidea” group.
To unsubscribe from this topic, visit https://groups.google.com/d/top
ic/privacyidea/DkXXIkmYBpA/unsubscribe.
To unsubscribe from this group and all its topics, send an email to p
rivacyidea+unsubscribe@googlegroups.com.
To post to this group, send email to privacyidea@googlegroups.com.
Visit this group at https://groups.google.com/group/privacyidea.
To view this discussion on the web visit https://groups.google.com/d/
msgid/privacyidea/8cdf04ab-ff7d-4842-b296-
79abfe504e0c%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Cornelius Kölbel
@cornelinux
+49 151 2960 1417

NetKnights GmbH
http://www.netknights.it
Landgraf-Karl-Str. 19, 34131 Kassel, Germany
Tel: +49 561 3166797, Fax: +49 561 3166798

Amtsgericht Kassel, HRB 16405
Geschäftsführer: Cornelius Kölbel

signature.asc (819 Bytes)

Hi,

even when i right the user name and password in options when i save the sms
gateway it remove them from option
and right them in parameters.

DaniOn Tuesday, February 7, 2017 at 12:29:16 PM UTC+2, Cornelius Kölbel wrote:

Hi Dani,

first of all: Good Choice! :wink:

Then:
DO NOT use the USERNAME and PASSWORD in the top settings. As stated, these
are used for basic authentication!
You need to leave this blank, since you do not use basic authentication.
In your case the usernam and password are passed as HTTP parameters. You
need to add these under options.
And in addion, you need to not add a column at the end of the options. It
should look like this:

https://lh3.googleusercontent.com/-fUhx_gc_UzI/WJmhVv9betI/AAAAAAAAADc/BPP5M116wR0s4OdN_IN7LPdCVX_RNqczgCLcB/s1600/Bildschirmfoto%2Bvom%2B2017-02-07%2B11-28-12.png

Then you can also take a look into the privacyidea.log, which might give
you some clues, in case you do not receive the SMS.

Kind regards
Cornelius

Am Dienstag, 7. Februar 2017 07:10:26 UTC+1 schrieb Dani Bittan:

Hi
I try To move from linotp to privacyidea but i have a problem with http
sms.
in linotp the setting work fine i can get sms otp the linotp setting are:

{“URL”:“http://1.1.111/scripts/smsgate.asp”,
“PARAMETER”: {
“username”:“user”,
“password”:“password”,
“validity”:“3”,
“source”:“ssl vpn otp”
},
“SMS_TEXT_KEY”:“message”,
“SMS_PHONENUMBER_KEY”:“target”,
“HTTP_Method”:“GET”,
“RETURN_SUCCESS”:“0”
}

I made the setting in privacyidea but its not working .

Thanks

Dani

https://lh3.googleusercontent.com/-Tc7Q11OWX8Y/WJlkhhokbtI/AAAAAAAAAJI/1bi9TY63R3UoHzno6KrlQiQLrFwwV2VWACLcB/s1600/pic1.JPG