HTTP SMS Gateway config

Hi,

I’ve installed privacyidea 2.13 on a Ubuntu server 14.04 through ppa.
Now it’s working with Static passwords, TOTP etc.

I will also configure it to deliver OTP via an HTTP SMS Gateway.
I’ve tried to configure the HTTP SMS provider, but p-idea generate wrong
string.
I can see in the log of the HTTP SMSGW server that phone number
is SMS_PHONENUMBER_KEY and message is SMS_TEXT_KEY

Do I miss some sign’s in the code or something? Seams that the system don’t
get the value/variable.

In the debug log, I can see that p-idea is choosing the right phonenumber
and a otp code. When I try to use this otp code, it’s valid and I get
further.

Hello John,

admitted, the documentation is still 2.12.
http://privacyidea.readthedocs.io/en/latest/configuration/tokenconfig/sms.html?highlight=sms#http-provider

You configured wrong OPTIONS.
The options are optional HTTP parameters sent to the SMS gateway.
I.e. if you enter “message”:“SMS_TEXT_KEY”, the HTTP Parameter

message:SMS_TEXT_KEY is added to the HTTP request.

Instead you need to use the tags {phone} and {otp}.

In your case this would be:

message: {otp}

number: {phone}

But you could also do:

message: Your OTP value is {otp}.
number: {phone}

…maybe you can send a pull request at github?
Please adapt this file:

Kind regards
CorneliusAm Mittwoch, den 13.07.2016, 06:07 -0700 schrieb John Olav Selland:

Thanks for your quick response.

I’ve attached a picture of the settings on the gateway. I don’t know
where I can find the config file, if it’s exist.
Sorry for not sending config in the first post.

If you want specific config files, tell me which and I’ll send them to
you.

Best regards, John Olav

On Wednesday, July 13, 2016 at 2:42:41 PM UTC+2, Cornelius Kölbel wrote:
SMS_PHONENUMBER_KEY is deprecated and should not be used
anymore.

    You should have sent your SMS config in the first place as my
    magic glass ball is broken.
    
    
    
    
    Read http://privacyidea.org/getting-help
    
    
    
    
    Cornelius Kölbel 
    +49 151 2960 1417
    
    NetKnights GmbH
    Http://NetKnights. It
    +49 561 3166 797
    
    
    
    
    -------- Ursprüngliche Nachricht --------
    Von: John Olav Selland <sella...@gmail.com> 
    Datum: 13.07.16 14:15 (GMT+01:00) 
    An: privacyidea <priva...@googlegroups.com> 
    Betreff: [privacyidea] HTTP SMS Gateway config 
    
    
    Hi,
    
    
    I've installed privacyidea 2.13 on a Ubuntu server 14.04
    through ppa.
    Now it's working with Static passwords, TOTP etc.
    
    
    I will also configure it to deliver OTP via an HTTP SMS
    Gateway.
    I've tried to configure the HTTP SMS provider, but p-idea
    generate wrong string.
    I can see in the log of the HTTP SMSGW server that phone
    number is SMS_PHONENUMBER_KEY and message is SMS_TEXT_KEY
    
    
    Do I miss some sign's in the code or something? Seams that the
    system don't get the value/variable.
    
    
    In the debug log, I can see that p-idea is choosing the right
    phonenumber and a otp code. When I try to use this otp code,
    it's valid and I get further.


Cornelius Kölbel
@cornelinux
+49 151 2960 1417

NetKnights GmbH
http://www.netknights.it
Landgraf-Karl-Str. 19, 34131 Kassel, Germany
Tel: +49 561 3166797, Fax: +49 561 3166798

Amtsgericht Kassel, HRB 16405
Geschäftsführer: Cornelius Kölbel

signature.asc (836 Bytes)

Thanks for your quick response.

I’ve attached a picture of the settings on the gateway. I don’t know where
I can find the config file, if it’s exist.
Sorry for not sending config in the first post.

If you want specific config files, tell me which and I’ll send them to you.

Best regards, John OlavOn Wednesday, July 13, 2016 at 2:42:41 PM UTC+2, Cornelius Kölbel wrote:

SMS_PHONENUMBER_KEY is deprecated and should not be used anymore.

You should have sent your SMS config in the first place as my magic glass
ball is broken.

Read http://privacyidea.org/getting-help

Cornelius Kölbel
+49 151 2960 1417

NetKnights GmbH
Http://NetKnights. It
+49 561 3166 797

-------- Ursprüngliche Nachricht --------
Von: John Olav Selland <sella...@gmail.com <javascript:>>
Datum: 13.07.16 14:15 (GMT+01:00)
An: privacyidea <priva...@googlegroups.com <javascript:>>
Betreff: [privacyidea] HTTP SMS Gateway config

Hi,

I’ve installed privacyidea 2.13 on a Ubuntu server 14.04 through ppa.
Now it’s working with Static passwords, TOTP etc.

I will also configure it to deliver OTP via an HTTP SMS Gateway.
I’ve tried to configure the HTTP SMS provider, but p-idea generate wrong
string.
I can see in the log of the HTTP SMSGW server that phone number
is SMS_PHONENUMBER_KEY and message is SMS_TEXT_KEY

Do I miss some sign’s in the code or something? Seams that the system
don’t get the value/variable.

In the debug log, I can see that p-idea is choosing the right phonenumber
and a otp code. When I try to use this otp code, it’s valid and I get
further.


Please read the blog post about getting help
https://www…org/getting-help/ https://www.privacyidea.org/getting-help/
.
privacyidea https://www.privacyidea.org/getting-help/
For professional services and consultancy regarding two factor
authentication please visit
https://netknights.it/en/leistungen/one-time-services/

In an enterprise environment you should get a SERVICE LEVEL AGREEMENT
which suites your needs for SECURITY, AVAILABILITY and LIABILITY:
https://netknights.it/en/leistungen/service-level-agreements/

You received this message because you are subscribed to the Google Groups
“privacyidea” group.
To unsubscribe from this group and stop receiving emails from it, send an
email to privacyidea...@googlegroups.com <javascript:>.
To post to this group, send email to priva...@googlegroups.com
<javascript:>.
Visit this group at https://groups.google.com/group/privacyidea.
To view this discussion on the web visit
https://groups.google.com/d/msgid/privacyidea/0aa2f22b-b78c-424d-b652-1e68b0db34b1%40googlegroups.com
https://groups.google.com/d/msgid/privacyidea/0aa2f22b-b78c-424d-b652-1e68b0db34b1%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

Thanks a lot for your help, the SMS Gateway is now working as it should.

Good luck with this nice product.

Best regards John OlavOn Wednesday, July 13, 2016 at 4:36:39 PM UTC+2, Cornelius Kölbel wrote:

Hello John,

admitted, the documentation is still 2.12.

http://privacyidea.readthedocs.io/en/latest/configuration/tokenconfig/sms.html?highlight=sms#http-provider

You configured wrong OPTIONS.
The options are optional HTTP parameters sent to the SMS gateway.
I.e. if you enter “message”:“SMS_TEXT_KEY”, the HTTP Parameter

message:SMS_TEXT_KEY is added to the HTTP request.

Instead you need to use the tags {phone} and {otp}.

In your case this would be:

message: {otp}

number: {phone}

But you could also do:

message: Your OTP value is {otp}.
number: {phone}

…maybe you can send a pull request at github?
Please adapt this file:

https://github.com/privacyidea/privacyidea/blob/master/doc/configuration/tokenconfig/sms.rst

Kind regards
Cornelius

Am Mittwoch, den 13.07.2016, 06:07 -0700 schrieb John Olav Selland:

Thanks for your quick response.

I’ve attached a picture of the settings on the gateway. I don’t know
where I can find the config file, if it’s exist.
Sorry for not sending config in the first post.

If you want specific config files, tell me which and I’ll send them to
you.

Best regards, John Olav

On Wednesday, July 13, 2016 at 2:42:41 PM UTC+2, Cornelius Kölbel wrote:
SMS_PHONENUMBER_KEY is deprecated and should not be used
anymore.

    You should have sent your SMS config in the first place as my 
    magic glass ball is broken. 
    
    
    
    
    Read http://privacyidea.org/getting-help 
    
    
    
    
    Cornelius Kölbel 
    +49 151 2960 1417 
    
    NetKnights GmbH 
    Http://NetKnights. It 
    +49 561 3166 797 
    
    
    
    
    -------- Ursprüngliche Nachricht -------- 
    Von: John Olav Selland <sella...@gmail.com> 
    Datum: 13.07.16 14:15 (GMT+01:00) 
    An: privacyidea <priva...@googlegroups.com> 
    Betreff: [privacyidea] HTTP SMS Gateway config 
    
    
    Hi, 
    
    
    I've installed privacyidea 2.13 on a Ubuntu server 14.04 
    through ppa. 
    Now it's working with Static passwords, TOTP etc. 
    
    
    I will also configure it to deliver OTP via an HTTP SMS 
    Gateway. 
    I've tried to configure the HTTP SMS provider, but p-idea 
    generate wrong string. 
    I can see in the log of the HTTP SMSGW server that phone 
    number is SMS_PHONENUMBER_KEY and message is SMS_TEXT_KEY 
    
    
    Do I miss some sign's in the code or something? Seams that the 
    system don't get the value/variable. 
    
    
    In the debug log, I can see that p-idea is choosing the right 
    phonenumber and a otp code. When I try to use this otp code, 
    it's valid and I get further. 


Cornelius Kölbel
corneliu...@netknights.it <javascript:>
+49 151 2960 1417

NetKnights GmbH
http://www.netknights.it
Landgraf-Karl-Str. 19, 34131 Kassel, Germany
Tel: +49 561 3166797, Fax: +49 561 3166798

Amtsgericht Kassel, HRB 16405
Geschäftsführer: Cornelius Kölbel

On Wednesday, July 13, 2016 at 4:36:39 PM UTC+2, Cornelius Kölbel wrote:

Hello John,

admitted, the documentation is still 2.12.

http://privacyidea.readthedocs.io/en/latest/configuration/tokenconfig/sms.html?highlight=sms#http-provider

You configured wrong OPTIONS.
The options are optional HTTP parameters sent to the SMS gateway.
I.e. if you enter “message”:“SMS_TEXT_KEY”, the HTTP Parameter

message:SMS_TEXT_KEY is added to the HTTP request.

Instead you need to use the tags {phone} and {otp}.

In your case this would be:

message: {otp}

number: {phone}

But you could also do:

message: Your OTP value is {otp}.
number: {phone}

…maybe you can send a pull request at github?
Please adapt this file:

https://github.com/privacyidea/privacyidea/blob/master/doc/configuration/tokenconfig/sms.rst

Kind regards
Cornelius

Am Mittwoch, den 13.07.2016, 06:07 -0700 schrieb John Olav Selland:

Thanks for your quick response.

I’ve attached a picture of the settings on the gateway. I don’t know
where I can find the config file, if it’s exist.
Sorry for not sending config in the first post.

If you want specific config files, tell me which and I’ll send them to
you.

Best regards, John Olav

On Wednesday, July 13, 2016 at 2:42:41 PM UTC+2, Cornelius Kölbel wrote:
SMS_PHONENUMBER_KEY is deprecated and should not be used
anymore.

    You should have sent your SMS config in the first place as my 
    magic glass ball is broken. 
    
    
    
    
    Read http://privacyidea.org/getting-help 
    
    
    
    
    Cornelius Kölbel 
    +49 151 2960 1417 
    
    NetKnights GmbH 
    Http://NetKnights. It 
    +49 561 3166 797 
    
    
    
    
    -------- Ursprüngliche Nachricht -------- 
    Von: John Olav Selland <sella...@gmail.com> 
    Datum: 13.07.16 14:15 (GMT+01:00) 
    An: privacyidea <priva...@googlegroups.com> 
    Betreff: [privacyidea] HTTP SMS Gateway config 
    
    
    Hi, 
    
    
    I've installed privacyidea 2.13 on a Ubuntu server 14.04 
    through ppa. 
    Now it's working with Static passwords, TOTP etc. 
    
    
    I will also configure it to deliver OTP via an HTTP SMS 
    Gateway. 
    I've tried to configure the HTTP SMS provider, but p-idea 
    generate wrong string. 
    I can see in the log of the HTTP SMSGW server that phone 
    number is SMS_PHONENUMBER_KEY and message is SMS_TEXT_KEY 
    
    
    Do I miss some sign's in the code or something? Seams that the 
    system don't get the value/variable. 
    
    
    In the debug log, I can see that p-idea is choosing the right 
    phonenumber and a otp code. When I try to use this otp code, 
    it's valid and I get further. 


Cornelius Kölbel
corneliu...@netknights.it <javascript:>
+49 151 2960 1417

NetKnights GmbH
http://www.netknights.it
Landgraf-Karl-Str. 19, 34131 Kassel, Germany
Tel: +49 561 3166797, Fax: +49 561 3166798

Amtsgericht Kassel, HRB 16405
Geschäftsführer: Cornelius Kölbel