Default Apache instead of PrivacyIDEA


#1

Hello,

Hopefully not a dumb question but after several days of working to get PrivacyIDEA installed I figured I would post a question here. The eventual goal is to integrate with FreeRADIUS to perform 2-FA on VPN requests to the Ubiquity router.

PrivacyIdea is currently running in a VirtualBox VM Ubuntu 16.04 Desktop with Debian 9 as the host. I installed using the Ubuntu instructions (Section 2.2 of the online guide). Things seemed to run smoothly but when I go to localhost in the browser I am greeted by the default ubuntu Apache website instead of any PrivacyIDEA site. I am wondering what could have gone wrong and what to check.

I installed
add-apt-repository ppa:privacyidea/privacyidea
apt-get update
apt-get install python-privacyidea privacyideaadm
apt-get install privacyidea-apache2

and created an admin user without problems.

the /var/log/privacyidea/privacyidea.log file is empty. My thought is that maybe there is a permissions issue somewhere.

Any help is appreciated. Thanks

Matt


#2

Do you call the site with http or https?
The default seems to be that you must call it with https.

In /etc/apache2/sites-available/privacyidea.conf you can enable automatic forward to https:

# If you want to forward http request to https enable the
# following virtual host.
<VirtualHost _default_:80>
       # This will enable the Rewrite capabilities
       RewriteEngine On

       # This checks to make sure the connection is not already HTTPS
       RewriteCond %{HTTPS} !=on
       RewriteRule ^/?(.*) https://%{SERVER_NAME}/$1 [R,L]
</VirtualHost>

Please verify that the site privacyidea is enabled in apache:

# ls -l /etc/apache2/sites-enabled/
total 0
lrwxrwxrwx 1 root root 35 Jul  2 16:33 privacyidea.conf -> ../sites-available/privacyidea.conf

If it is not enable, just do:

a2ensite privacyidea
systemctl restart apache2.service

#3

I had already checked that the site was enabled so it was a bit mystifying. I needed to specify https:// and then I could log in!

Thanks for your help, saved me a lot of head banging