Connection reject does not work as expected when running freeradius as a service

Hi!
I’m using a fresh install of PrivacyIDEA 3.6 on Ubuntu 20.04.
I have configured "TIMEOUT = 30 " parameter in /etc/privacyidea/rlm_perl.ini.
When I test freeradius with “freeradius -X” command everything works as expected so if I ignore (or press Decline button) push request on my phone then my connection attempt is rejected after ~30 seconds (or right after pressing Decline button).
But when I start freeradius as a service my connection attempt continues for ~1min 30sec before my connection attempt rejects (even if I press Decline button).
If I press Allow button everything works as expected in both cases.
What could be the reason of that?
Thanks!

The reason might be, that in one case you are issuing a test request and in the other case you are trying to login via your RADIUSClient/VPN/Application. Am I right?

Actually no :slight_smile: I do absolutely the same process in both cases. Same user, same push (poll only) token, same phone with PI Authenticator app. Tried on several users - same result.
I’m using PI for RD Gateway if it matters.