Privacyidea 3 Radius Plugin

#1

Hello Cornelius,

is there already a .deb for the radius plugin for the new version
or should i build it from the github repo?

As a side note i had to install default-libmysqlclient-dev on bionic to get rid of a “cannot find libmysqlclient.so.20” error.

Best regards

0 Likes

#2

No, there is no new RADIUS plugin at the moment.
You could also use the old one, from the launchpad ppa.
We decided to split the releases of plugins and server.

0 Likes

#3

Hi,

you don’t need the -dev package. For me installing
libmysqlclient20 was all that was needed.
I’ve not yet filed an issue in github.

Jochen

0 Likes

#4

I tried to use the old one from the ppa but it doesn’t seem to play nice with freeradius 3.
Do you have an ETA for the new plugin?

0 Likes

#5

The plugin works just the same with freeradius 3.
The only difference is, that the configuration of freeradius 3 changed and you need to change the config file. Nothing else.
You can read into https://www.privacyidea.org/two-factor-authentication-with-otp-on-centos-7/
or it is simple as that:
https://github.com/privacyidea/FreeRADIUS/issues/11

0 Likes