Invalid command 'WSGIScriptAlias', perhaps misspelled or defined by a module not included in the server configuration


the ownership should look like this:

-rw-r–r–. 1 privacyidea root 4109 Feb 7 2023 dictionary
-rw-------. 1 privacyidea root 96 Aug 9 11:33 enckey
drwxr-xr-x. 4 privacyidea root 4096 Aug 9 11:33 gpg
-rw-r–r–. 1 privacyidea root 451 Feb 7 2023 NetKnights.pem
-rw-r-----. 1 privacyidea root 1041 Aug 9 11:33 pi.cfg
-rw-r–r–. 1 privacyidea root 201 Feb 7 2023 privacyideaapp.wsgi
-rw-------. 1 privacyidea root 1679 Aug 9 11:33 private.pem
-rw-r–r–. 1 privacyidea root 451 Aug 9 11:33 public.pem

Please use our documentation!!

Add a dedicated user for the privacyIDEA server and change some ownerships:

$ chown privacyidea:privacyidea /opt/privacyidea /etc/privacyidea /var/log/privacyidea



1 Like

I actually have a signon screen …

Feeling quite emotional… :rofl: :joy:

I tried to authenticate but received the following error:

Authentication failed. 500 Internal Server Error: The server encountered an internal error and was unable to complete your request. Either the server is overloaded or there is an error in the application.

I will investigate further but thanks for your assistance.


from this point, you can continue in the documentation:

On youtube you can also find some videos.



1 Like

I had previously executed all of the pi-manage command line commands. They worked out of the box…

I just need to workout why the initial http authentication is failing.

Also, we already use privacyidea on Red Hat 7, so configuring the LDAP connection and generating the tokens etc should be fairly straightforward once I have logged in.


Hi Julio,

The application is up and running and configured with connectivity to our Active Directory server.

I have also generated a QR token for my user account but havent yet tested it.

Its been an emotional rollercoaster of a journey but its done now and I am delighted. :grin: :grin:

Thanks again for all your help.


1 Like