Backup and Restore Errors/Not Working

Ok, so what I am trying to do is backup 1 system and restore to another system, so this provides a warm standby. Warm standby is a clone of the production system after everything is installed so encryption key and sql are both the same and I have changed IP’s and hostname. I can login to both systems privacyidea gui.

Both systems are:
Ubuntu 20.04
PrivacyIDEA 3.5.1

I run the following command:
/opt/privacyidea/bin/pi-manage backup create -d /opt/backup

With the following output:
tar: Removing leading /' from member names tar: Removing leading /’ from hard link targets
tar: The following options were used after any non-optional arguments in archive create or update mode. These options are positional and affect only arguments that follow them. Please, rearrange them properly.
tar: --exclude ‘/etc/privacyidea/enckey’ has no effect
tar: Exiting with failure status due to previous errors

When I run the restore command on the second server:
/opt/privacyidea/bin/pi-manage backup restore “filename”

The standby system does not have any of the updates that system 1 has, for example I created realms and resolvers and these are not on the second system.

Does anyone have any ideas.


What is actually in the tgz backup?

I have etc with the config files in and opt/backup with the sql dump file in.

OK, if the sql dump is in it, you may check the contents of the dumb.

But it might also be: you need to restart the web server on the backup, so that it rereads the cached config changes from the DB.

Ok, thanks will take a look.

I have been trying to work out the best way of having either active/active or standby, I was going to try the sql replication group setup I read on another post.