AW: Re: issues sending smtp with email-otp

Hi Stephan,
Are you a github user?Would you like to add an issue for this? Otherwise I will do this later…
Thanks a lotCornelius

Cornelius KölbelCornelius.koelbel@netknights.it+49 151 2960 1417
NetKnights GmbHhttp://netknights.itLandgraf-Karl-Str. 19, 34131 Kassel, GermanyTel: +49 561 3166797, Fax: +49 561 3166798
Amtsgericht Kassel, HRB 16405Geschäftsführer: Cornelius Kölbel-------- Ursprüngliche Nachricht --------
Von: Stephen Hobbs hobbs123@gmail.com
Datum: 04.11.2015 20:32 (GMT+01:00)
An: privacyidea privacyidea@googlegroups.com
Betreff: Re: issues sending smtp with email-otp

Cornelius

Thank you that fixed it. I found a minor bug with TLS activation under Config->Tokens->Email. If TLS support is checked it can not be unchecked.

command line fix:
echo “USE privacyidea;UPDATE config set config.value=’’ where config.key=‘email.tls’;” | mysql -u privacyidea -p

Stephen

On Tuesday, November 3, 2015 at 8:43:44 PM UTC-8, Cornelinux K wrote:Hello Stephan,

you need to create a policy

    scope:authentication

    action:challenge_response=email

http://privacyidea.readthedocs.org/en/latest/policies/authentication.html#challenge-response

In version 2.8 this will not be necessary anymore, since an email token

is — lets say — always in challenge response mode.

You can also run HOTP and TOTP in challenge response (first sending PIN

and then OTP) but for this you will need to define

    action:challenge_response=hotp totp email

Kind regards

Cornelius

Am Dienstag, den 03.11.2015, 17:13 -0800 schrieb Stephen Hobbs:

I have installed privacyidea 2.7 and successfully tested HOTP tokens.

I am unable to get email-otp working I have tried using a remote and

local smtp server, with and without smtp authentication and TLS

on/off. When I test the authentication by sending the OTP pin no email

are sent or received. Any ideas to debug very welcome.

You received this message because you are subscribed to the Google

Groups “privacyidea” group.

To unsubscribe from this group and stop receiving emails from it, send

an email to privacyidea...@googlegroups.com.

To post to this group, send email to priva...@googlegroups.com.

To view this discussion on the web visit

https://groups.google.com/d/msgid/privacyidea/bc106c30-986e-4fea-ae40-c8dc706ada0a%40googlegroups.com.

For more options, visit https://groups.google.com/d/optout.

Cornelius Kölbel

corneliu…@netknights.it

+49 151 2960 1417

NetKnights GmbH

http://www.netknights.it

Landgraf-Karl-Str. 19, 34131 Kassel, Germany

Tel: +49 561 3166797, Fax: +49 561 3166798

Amtsgericht Kassel, HRB 16405

Geschäftsführer: Cornelius Kölbel

You received this message because you are subscribed to the Google Groups “privacyidea” group.

To unsubscribe from this group and stop receiving emails from it, send an email to privacyidea+unsubscribe@googlegroups.com.

To post to this group, send email to privacyidea@googlegroups.com.

To view this discussion on the web visit https://groups.google.com/d/msgid/privacyidea/f4a02982-1a02-4352-b2ff-79458a032749%40googlegroups.com.

For more options, visit https://groups.google.com/d/optout.

Hi Stephan,

I added an issue to github to fix this.

Kind regards
CorneliusAm Mittwoch, den 04.11.2015, 21:24 +0100 schrieb Cornelius Kölbel:

Hi Stephan,

Are you a github user?
Would you like to add an issue for this?
Otherwise I will do this later…

Thanks a lot
Cornelius

Cornelius Kölbel
Cornelius.koelbel@netknights.it
+49 151 2960 1417

NetKnights GmbH
http://netknights.it
Landgraf-Karl-Str. 19, 34131 Kassel, Germany
Tel: +49 561 3166797, Fax: +49 561 3166798

Amtsgericht Kassel, HRB 16405
Geschäftsführer: Cornelius Kölbel

-------- Ursprüngliche Nachricht --------
Von: Stephen Hobbs hobbs123@gmail.com
Datum: 04.11.2015 20:32 (GMT+01:00)
An: privacyidea privacyidea@googlegroups.com
Betreff: Re: issues sending smtp with email-otp

Cornelius

Thank you that fixed it. I found a minor bug with TLS activation under
Config->Tokens->Email. If TLS support is checked it can not be
unchecked.

command line fix:
echo “USE privacyidea;UPDATE config set config.value=’’ where
config.key=‘email.tls’;” | mysql -u privacyidea -p

Stephen

On Tuesday, November 3, 2015 at 8:43:44 PM UTC-8, Cornelinux K wrote:
Hello Stephan,

    you need to create a policy 
    
            scope:authentication 
            action:challenge_response=email 
    
    http://privacyidea.readthedocs.org/en/latest/policies/authentication.html#challenge-response 
    
    In version 2.8 this will not be necessary anymore, since an
    email token 
    is --- lets say --- always in challenge response mode. 
    
    You can also run HOTP and TOTP in challenge response (first
    sending PIN 
    and then OTP) but for this you will need to define 
    
            action:challenge_response=hotp totp email 
    
    Kind regards 
    Cornelius 
    
    
    
    Am Dienstag, den 03.11.2015, 17:13 -0800 schrieb Stephen
    Hobbs: 
    > I have installed privacyidea 2.7 and successfully tested
    HOTP tokens. 
    > I am unable to get email-otp working I have tried using a
    remote and 
    > local smtp server,  with and without smtp authentication and
    TLS 
    > on/off. When I test the authentication by sending the OTP
    pin no email 
    > are sent or received. Any ideas to debug very welcome. 
    > 
    > -- 
    > You received this message because you are subscribed to the
    Google 
    > Groups "privacyidea" group. 
    > To unsubscribe from this group and stop receiving emails
    from it, send 
    > an email to privacyidea...@googlegroups.com. 
    > To post to this group, send email to
    priva...@googlegroups.com. 
    > To view this discussion on the web visit 
    >
    https://groups.google.com/d/msgid/privacyidea/bc106c30-986e-4fea-ae40-c8dc706ada0a%40googlegroups.com. 
    > For more options, visit https://groups.google.com/d/optout. 
    
    -- 
    Cornelius Kölbel 
    corneliu...@netknights.it 
    +49 151 2960 1417 
    
    NetKnights GmbH 
    http://www.netknights.it 
    Landgraf-Karl-Str. 19, 34131 Kassel, Germany 
    Tel: +49 561 3166797, Fax: +49 561 3166798 
    
    Amtsgericht Kassel, HRB 16405 
    Geschäftsführer: Cornelius Kölbel 


Cornelius Kölbel
@cornelinux
+49 151 2960 1417

NetKnights GmbH
http://www.netknights.it
Landgraf-Karl-Str. 19, 34131 Kassel, Germany
Tel: +49 561 3166797, Fax: +49 561 3166798

Amtsgericht Kassel, HRB 16405
Geschäftsführer: Cornelius Kölbel

signature.asc (836 Bytes)