A bug with "user details"(/user/details/)

Hello Cornelius!

Could you please check if it is a bug in your deployment. I have a strange
behavior of user details page which gets users from LDAP resolver…
How to reproduce:
Under admin scope go to Users -> All users -> click on any username in the
"username" column. You’ll see a details page for this user with all the
fields grabbed from LDAP like username, phone, email etc… Everything is OK
here.
Then click “view user in audit log”. While on this page click on a the
username in the column “user” and you’ll get on user details page once
again, BUT with no details in any of the fields(username, phone, email
etc.). They all are blank. Istead I have my own login name in Mobile field

PI ver is 2.11

I think I understood the problem.
I submitted an issue


and will push the fix.

Kind regards
CorneliusAm Freitag, den 01.04.2016, 06:17 -0700 schrieb Sergey Kolosovski:

    First note: When you go from the user details to the audit log
    it only 
    matches the username - not the realm and resolver. 
    I.e. you could see the audit logs of selectedUser@realm1 and 
    selectedUser@realm2. 

Yes, and I don’t have problems with it.
The problem is when I go from this audit log to user details. PI
correctly identifies the realm, but doesn’t show any user details, for
example when I get from audit log to user details by clicking on user
name I’m moving to the following url:
https:///#/user/details//

these fields (the default one) and are correct

    Then: You should check if you are logged out in the meantime. 

yes. I am logged in ad I can browse all other sections of PI

    Can you please activate developer view in your browser and
    watch out for 
    errors in the debug output or the network output? 

I’m dot sure where exactly to dig there, but I see one error:

Please not the checkbox in red square. If it checked I cannot
reproduce. Everything works.
I also checked in Chrome’s anonymous mode - it is reproduced, this
mean that extensions don’t affect.
In Firefox - it doesn’t reproduced, so it works in ff.

Please read the blog post about getting help
https://www.privacyidea.org/getting-help/.

For professional services and consultancy regarding two factor
authentication please visit
https://netknights.it/en/leistungen/one-time-services/

In an enterprise environment you should get a SERVICE LEVEL AGREEMENT
which suites your needs for SECURITY, AVAILABILITY and LIABILITY:
https://netknights.it/en/leistungen/service-level-agreements/

You received this message because you are subscribed to the Google
Groups “privacyidea” group.
To unsubscribe from this group and stop receiving emails from it, send
an email to privacyidea+unsubscribe@googlegroups.com.
To post to this group, send email to privacyidea@googlegroups.com.
Visit this group at https://groups.google.com/group/privacyidea.
To view this discussion on the web visit
https://groups.google.com/d/msgid/privacyidea/4d985882-cd35-4c72-9244-84f3effc6340%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


Cornelius Kölbel
@cornelinux
+49 151 2960 1417

NetKnights GmbH
http://www.netknights.it
Landgraf-Karl-Str. 19, 34131 Kassel, Germany
Tel: +49 561 3166797, Fax: +49 561 3166798

Amtsgericht Kassel, HRB 16405
Geschäftsführer: Cornelius Kölbel

signature.asc (836 Bytes)

Hello Sergey,

I can not reproduce this.

First note: When you go from the user details to the audit log it only
matches the username - not the realm and resolver.
I.e. you could see the audit logs of selectedUser@realm1 and
selectedUser@realm2.

When clicking on a username you could return to the OTHER user.

Then: You should check if you are logged out in the meantime.
Can you please activate developer view in your browser and watch out for
errors in the debug output or the network output?

THanks a lot
CorneliusAm Freitag, den 01.04.2016, 04:54 -0700 schrieb Sergey Kolosovski:

Hello Cornelius!

Could you please check if it is a bug in your deployment. I have a
strange behavior of user details page which gets users from LDAP
resolver…
How to reproduce:
Under admin scope go to Users -> All users -> click on any username in
the “username” column. You’ll see a details page for this user with
all the fields grabbed from LDAP like username, phone, email etc…
Everything is OK here.
Then click “view user in audit log”. While on this page click on a the
username in the column “user” and you’ll get on user details page once
again, BUT with no details in any of the fields(username, phone, email
etc.). They all are blank. Istead I have my own login name in Mobile
field

Please read the blog post about getting help
https://www.privacyidea.org/getting-help/.

For professional services and consultancy regarding two factor
authentication please visit
https://netknights.it/en/leistungen/one-time-services/

In an enterprise environment you should get a SERVICE LEVEL AGREEMENT
which suites your needs for SECURITY, AVAILABILITY and LIABILITY:
https://netknights.it/en/leistungen/service-level-agreements/

You received this message because you are subscribed to the Google
Groups “privacyidea” group.
To unsubscribe from this group and stop receiving emails from it, send
an email to privacyidea+unsubscribe@googlegroups.com.
To post to this group, send email to privacyidea@googlegroups.com.
Visit this group at https://groups.google.com/group/privacyidea.
To view this discussion on the web visit
https://groups.google.com/d/msgid/privacyidea/9ab3ccaf-bbc0-425e-b0ea-5fba41a41fe1%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


Cornelius Kölbel
@cornelinux
+49 151 2960 1417

NetKnights GmbH
http://www.netknights.it
Landgraf-Karl-Str. 19, 34131 Kassel, Germany
Tel: +49 561 3166797, Fax: +49 561 3166798

Amtsgericht Kassel, HRB 16405
Geschäftsführer: Cornelius Kölbel

signature.asc (836 Bytes)

First note: When you go from the user details to the audit log it only
matches the username - not the realm and resolver.
I.e. you could see the audit logs of selectedUser@realm1 and
selectedUser@realm2.

Yes, and I don’t have problems with it.
The problem is when I go from this audit log to user details. PI correctly
identifies the realm, but doesn’t show any user details, for example when I
get from audit log to user details by clicking on user name I’m moving to
the following url:
https:///#/user/details//
these fields (the default one) and are correct

Then: You should check if you are logged out in the meantime.

yes. I am logged in ad I can browse all other sections of PI

Can you please activate developer view in your browser and watch out for
errors in the debug output or the network output?

I’m dot sure where exactly to dig there, but I see one error:

https://lh3.googleusercontent.com/-yMGs_CNkqNE/Vv50H01KToI/AAAAAAAALx0/_sNtWT5eEgI8fB4fJtnMGAsBRzIHiRahA/s1600/Untitled.png

Please not the checkbox in red square. If it checked I cannot reproduce.
Everything works.
I also checked in Chrome’s anonymous mode - it is reproduced, this mean
that extensions don’t affect.
In Firefox - it doesn’t reproduced, so it works in ff.

thank you, Cornelius!